Settlement delays have now been resolved.
All transactions have now reached their intended terminal status.
Regular processing timings have resumed.
Impact start time: 10/02/2026, 12:30 UTC
Impact end time: 10/02/2026, 14:39 UTC
Client actions: None
Resolved
Settlement delays have now been resolved.
All transactions have now reached their intended terminal status.
Regular processing timings have resumed.
Impact start time: 10/02/2026, 12:30 UTC
Impact end time: 10/02/2026, 14:39 UTC
Client actions: None
Investigating
Weโre seeing delays in settlement notifications via our banking partner in the EU. No action needed on your end. Weโre monitoring closely.
Impact start time: 10/02/2026, 12:30 UTC
Client actions: None