Upon further investigation, we have identified that the settlement delays are due to a maintenance window. All withdrawal requests initiated during this maintenance window will be processed after the maintenance ends.
Impact start time: 19/02/2026, 21:10 UTC
Impact end time: 19/02/2026, 23:30 UTC
Client actions: None
Resolved
Upon further investigation, we have identified that the settlement delays are due to a maintenance window. All withdrawal requests initiated during this maintenance window will be processed after the maintenance ends.
Impact start time: 19/02/2026, 21:10 UTC
Impact end time: 19/02/2026, 23:30 UTC
Client actions: None
Identified
Weโre seeing degraded performance in payout. Our clients may encounter delays in settlement. Our engineering team is actively investigating the issue.
Impact start time: 19/02/2026, 21:10 UTC
Impact end time: Ongoing
Client actions: None