Resolved
Normal service has been restored. Clients should now see normal behaviour using verified payouts, VOP and Signup+ in th EU.
Impact start time: 28/02/2026, 22:00 GMT
Impact end time: 28/02/2026, 22:30 GMT
Client actions: None
Monitoring
The system has recovered and we are currently monitoring its activity. Clients should now see normal behaviour using verified payouts, VOP and Signup+ in th EU.
Impact start time: 28/02/2026, 22:00 GMT
Impact end time: 28/02/2026, 22:30 GMT
Client actions: None
Investigating
We are currently experiencing a service disruption affecting verified payouts, VOP and Signup+, causing payouts settlement delays in the EU. We are investigating this.
Impact start time: 28/02/2026, 22:00 GMT
Client actions: None