Resolved
The observed behaviour was not due to degraded performance, our alerting was likely too sensitive. Payouts are processing as normal.
Client actions: None
Investigating
Weโre seeing delays in settlement for payouts via our banking partner in the EU. No action needed on your end. Weโre monitoring closely.
Impact start time: 13/03/2026, 18:00 UTC
Client actions: None