You may have experienced delays in EUR payment settlements. This is now resolved and EUR payments are settling at a timely manner.
Impact start time: 02/04/2026, 12:32 UTC
Impact end time: 02/04/2026, 15:02 UTC
Client actions: None
Resolved
You may have experienced delays in EUR payment settlements. This is now resolved and EUR payments are settling at a timely manner.
Impact start time: 02/04/2026, 12:32 UTC
Impact end time: 02/04/2026, 15:02 UTC
Client actions: None
Monitoring
You may have experienced delays in EUR payment settlements. This is now resolved and EUR payments are settling at a timely manner.
Impact start time: 02/04/2026, 12:32 UTC
Impact end time: 02/04/2026, 15:02 UTC
Client actions: None
Resolved
We have resolved the issue with our banking provider that was causing delays in EUR payment settlements. This is now resolved and EUR payments are settling at a timely manner.
Impact start time: 02/04/2026, 12:32 UTC
Impact end time: 02/04/2026, 15:02 UTC
Client actions: None
Monitoring
We have resolved the issue with our banking provider that was causing delays in EUR payment settlements. Our systems are now processing these payments in a timely manner, and we have confirmed that the backlog is clearing.
Impact start time: 02/04/2026, 12:32 UTC
Impact end time: 02/04/2026, 15:02 UTC
Client actions: None
Identified
EUR payments are experiencing degraded performance, with settlement delays. We are still working with our banking partner to resume settlement service.
Impact start time: 02/04/2026, 12:32 UTC
Client actions: None
Identified
EUR payments are experiencing degraded performance, with settlement delays. We are investigating with our banking partner.
Impact start time: 02/04/2026, 12:32 UTC
Client actions: None