We experienced a degraded performance on our Payments products. You may have experienced delays in EUR Payment settlement. The service has recovered and payments are settling in a timely manner.
Impact start time: 14/04/2026, 21:03 UTC
Impact end time: 14/04/2026, 21:49 UTC
Client actions: None
Resolved
We experienced a degraded performance on our Payments products. You may have experienced delays in EUR Payment settlement. The service has recovered and payments are settling in a timely manner.
Impact start time: 14/04/2026, 21:03 UTC
Impact end time: 14/04/2026, 21:49 UTC
Client actions: None
Identified
EUR payments are experiencing degraded performance, with settlement delays. We are investigating with our banking partner.
Impact start time: 14/04/2026, 21:03 UTC
Client actions: None