As of 02:50 UTC, all the remaining EUR payins and payouts affected by the delayed settlement degradation have reached a final status and payments are settling as normal.
Impact start time: 18/04/2026, 19:17 UTC
Impact end time: 19/04/2026, 02:50 UTC
Client actions: None
Resolved
As of 02:50 UTC, all the remaining EUR payins and payouts affected by the delayed settlement degradation have reached a final status and payments are settling as normal.
Impact start time: 18/04/2026, 19:17 UTC
Impact end time: 19/04/2026, 02:50 UTC
Client actions: None
Identified
Our banking partner has confirmed that as of 21:20 UTC, all payments are settling as normal. However payments initiated between 19:17 and 21:20 UTC may not have reached a final status and could take a few hours to do so. We will provide further updates once all affected payments have reached a final status.
Client actions: None
Identified
Our banking partner has identified the issue causing delayed settlement of EUR payins and payouts and is working on a fix.
Impact start time: 18/04/2026, 19:17 UTC
Client actions: None
Investigating
We are experiencing a service degradation affecting EUR payments. Clients may be seeing delayed settlement of EUR payins and payouts. We are investigating this with our banking partner.
Impact start time: 18/04/2026, 19:17 UTC
Client actions: None