You may have experienced delayed settlement for PLN Payouts during the timeframe specified. The service has now recovered and Payouts are settling at normal rate.
Impact start time: 25/04/2026, 19:30 UTC
Impact end time: 25/04/2026, 20:00 UTC
Client actions: None
Resolved
You may have experienced delayed settlement for PLN Payouts during the timeframe specified. The service has now recovered and Payouts are settling at normal rate.
Impact start time: 25/04/2026, 19:30 UTC
Impact end time: 25/04/2026, 20:00 UTC
Client actions: None
Monitoring
You may have experienced delayed settlement for PLN Payouts during the timeframe specified. The service has now recovered and Payouts are settling at normal rate.
Impact start time: 25/04/2026, 19:30 UTC
Impact end time: 25/04/2026, 20:00 UTC
Client actions: None