You may have experienced delays in Payment and Payout settlement during the timeframe below. This has now been resolved, Payments and Payouts are settling in a timely manner.
Impact start time: 28/04/2026, 21:00 UTC
Impact end time: 28/04/2026, 21:40 UTC
Client actions: None
Resolved
You may have experienced delays in Payment and Payout settlement during the timeframe below. This has now been resolved, Payments and Payouts are settling in a timely manner.
Impact start time: 28/04/2026, 21:00 UTC
Impact end time: 28/04/2026, 21:40 UTC
Client actions: None
Identified
We are currently investigating an issue causing delays in payment settlements and payouts. Our engineering team is working to resolve this as quickly as possible. No action needed
Impact start time: 28/04/2026, 21:00 UTC
Client actions: None