We experienced a service degradation with GBP payouts due to an issue with our banking partner. Clients may have seen delayed settlement of payouts. Normal service has resumed.
Impact start time: 09/05/2026, 06:10 UTC
Impact end time: 09/05/2026, 07:18 UTC
Client actions: None
Resolved
We experienced a service degradation with GBP payouts due to an issue with our banking partner. Clients may have seen delayed settlement of payouts. Normal service has resumed.
Impact start time: 09/05/2026, 06:10 UTC
Impact end time: 09/05/2026, 07:18 UTC
Client actions: None
Investigating
We are currently experiencing a service degradation with GBP payouts. Clients may be seeing delayed settlement of payouts. We are actively investigating with our Banking Partner.
Impact start time: 09/05/2026, 06:10 UTC
Client actions: None