We experienced a degraded performance on PLN payouts due to an issue with our banking partner causing delayed settlements. All transactions have now reached their intended terminal status and new payouts are are settling in a timely manner.
Impact start time: 03/06/2026, 13:05 UTC
Impact end time: 03/06/2026, 13:50 UTC
Client actions: None
Resolved
We experienced a degraded performance on PLN payouts due to an issue with our banking partner causing delayed settlements. All transactions have now reached their intended terminal status and new payouts are are settling in a timely manner.
Impact start time: 03/06/2026, 13:05 UTC
Impact end time: 03/06/2026, 13:50 UTC
Client actions: None
Identified
We are currently experiencing degraded performance affecting PLN payout settlements. Clients may encounter delays when initiating PLN payouts. Our engineering team is actively investigating the issue.
Impact start time: 03/06/2026, 13:05 UTC
Client actions: None