We experienced a degraded performance on our Payments products. You may have experienced delays in EUR Payment settlement. The service has recovered and payments are settling in a timely manner.
Impact start time: 05/06/2026, 10:15 UTC
Impact end time: 05/06/2026, 13:45 UTC
Client actions: None
Resolved
We experienced a degraded performance on our Payments products. You may have experienced delays in EUR Payment settlement. The service has recovered and payments are settling in a timely manner.
Impact start time: 05/06/2026, 10:15 UTC
Impact end time: 05/06/2026, 13:45 UTC
Client actions: None
Monitoring
We experienced a degraded performance on our Payments products. Clients may have seen settlement delays from 10:15 to 12:25 UTC and from 12:50 to 13:45 UTC. The service has recovered, weโre monitoring closely.
Impact start time: 05/06/2026, 10:15 UTC
Impact end time: 05/06/2026, 13:45 UTC
Client actions: None