We experienced a degraded performance with our Payments API, which may have caused some payments to encounter delays and errors. This has now been resolved.
Impact start time: 19/09/2025, 23:10 BST
Impact end time: 19/09/2025, 23:57 BST
Client actions: None
Resolved
We experienced a degraded performance with our Payments API, which may have caused some payments to encounter delays and errors. This has now been resolved.
Impact start time: 19/09/2025, 23:10 BST
Impact end time: 19/09/2025, 23:57 BST
Client actions: None
Investigating
We are currently experiencing a degraded performance with our Payments API. Payments may experience latencies and errors. Our teams are currently investigating the issue.
Impact start time: 19/09/2025, 23:10 UTC
Client actions: None