We experienced a degraded performance on our Payments and Payout products.
You may have experienced delays in Payment settlement notifications during this time window.
The service has recovered and is operating normally.
Impact start time: 29/10/2025, 03:00 UTC
Impact end time: 29/10/2025, 05:20 UTC
Client actions: None
Resolved
We experienced a degraded performance on our Payments and Payout products.
You may have experienced delays in Payment settlement notifications during this time window.
The service has recovered and is operating normally.
Impact start time: 29/10/2025, 03:00 UTC
Impact end time: 29/10/2025, 05:20 UTC
Client actions: None
Monitoring
We experienced a degraded performance on our Payments and Payout products.
You may have experienced delays in Payment settlement notifications during this time window.
The service has recovered and is operating normally.
Impact start time: 29/10/2025, 03:00 UTC
Impact end time: 29/10/2025, 05:20 UTC
Client actions: None