TrueLayer

Report a problemSubscribe to updates
Powered by
Privacy policy

·

Terms of service
EU Payment Settlement Delays
Resolved·Degraded performance

Settlement delays have been resolved. All funds have now reached end-user accounts as expected. Normal settlement processing have resumed.

Impact start time: 14/12/2025, 21:58 UTC

Impact end time: 14/12/2025, 22:35 UTC

Client actions: None

Sun, Dec 14, 2025, 10:44 PM
(5 months ago)
·
Affected components
Dec 14, 2025, 09:58 PM
10:44 PM
Updates

Resolved

Settlement delays have been resolved. All funds have now reached end-user accounts as expected. Normal settlement processing have resumed.

Impact start time: 14/12/2025, 21:58 UTC

Impact end time: 14/12/2025, 22:35 UTC

Client actions: None

Sun, Dec 14, 2025, 10:44 PM

Investigating

We’re seeing delays in settlement notifications via our banking partner in the EU. No action needed on your end. We’re monitoring closely.

Impact start time: 14/12/2025, 21:58 UTC

Client actions: None

Sun, Dec 14, 2025, 10:22 PM(22 minutes earlier)