Upon further investigation, we assessed that this incident did not impact SignUp+ and Verification.
The status page has been amended accordingly.
Impact start time: 15/12/2025, 18:51 UTC
Impact end time: 15/12/2025, 19:51 UTC
Client actions: None
Resolved
Upon further investigation, we assessed that this incident did not impact SignUp+ and Verification.
The status page has been amended accordingly.
Impact start time: 15/12/2025, 18:51 UTC
Impact end time: 15/12/2025, 19:51 UTC
Client actions: None
Resolved
Investigation has resumed, and we have discovered an unexpected increase in traffic on one of our endpoints that lasted about 1 hour.
You may have experienced an increased latency with our PIS & AIS products during this timeframe.
Regular service has been restored, and this incident is now resolved, with the impact being over as of last night at 19:51 GMT.
Impact start time: 15/12/2025, 18:51 UTC
Impact end time: 15/12/2025, 19:51 UTC
Client actions: None
Monitoring
Our engineering team is actively investigating the root cause of this incident. The next update will be shared in the morning during business hours.
Service still holds for both PIS and AIS products.
Impact end time: 15/12/2025, 19:51 UTC
Client actions: None
Monitoring
Service for our PIS and AIS products has been restored, and we are no longer seeing errors.
Root cause has not yet been identified; our engineering team is actively investigating.
Impact end time: 15/12/2025, 19:51 UTC
Client actions: None
Monitoring
We have experienced degraded performance with our Payments API and Data API. Clients might have observed delays or timeouts when creating pay-ins and retrieving data, or when accessing account or transaction information. Our engineering team is working on assessing the root cause, but we're seeing that the APIs are now recovering. We are monitoring.
Impact end time: 15/12/2025, 18:51 UTC
Client actions: None
Investigating
We are experiencing degraded performance with our Payments API and Data API. Clients may experience delays or timeouts when creating pay-ins. Clients may observe delays in data retrieval or timeouts when accessing account or transaction information. Our engineering team is working on assessing the root cause.
Impact start time: 15/12/2025, 18:51 UTC
Client actions: None