Resolved
Normal service has been restored. EU Payouts should now be reaching their terminal status normally.
Impact start time: 06/02/2026, 09:04 UTC
Impact end time: 06/02/2026, 10:15 UTC
Client actions: None
Investigating
We are currently experiencing a service disruption. Payouts may be experiencing settlement delays in the EU. We are investigating this.
Impact start time: 06/02/2026, 09:04 GMT
Client actions: None