Resolved
Payouts are no longer experiencing settlement delays as normal service has been restored.
Impact start time: 22/07/2026, 09:17 BST
Impact end time: 22/07/2026, 11:58 BST
Client actions: None
Monitoring
Payouts are no longer experiencing settlement delays as normal service has been restored. Our teams are currently monitoring and resolving the backlog of transactions.
Impact start time: 22/07/2026, 09:17 BST
Impact end time: 22/07/2026, 10:22 BS
Client actions: None
Investigating
Payouts are currently experiencing some settlement delays. We are investigating.
Impact start time: 22/07/2026, 09:17 BST
Client actions: None
Investigating
Payouts are currently experiencing some settlement delays. We are investigating.
Impact start time: 22/07/2026, 09:17 BST
Client actions: None