This incident has been resolved.
Payout acceptance rates have returned to normal rates.
What happened: A change deployed on 20/07/2026 at 09:43 UTC inadvertently altered our payout retry logic, causing some errors that should have been retried to be treated as terminal. This resulted in a temporary increase in payout failure rates.
What we did: We identified the root cause, deployed a fix restoring the previous retry behaviour, and confirmed via monitoring that acceptance rates are back to baseline.
We apologise for any inconvenience caused and are working on preventative measures to avoid a recurrence.
Impact start time: 20/07/2026, 09:43 UTC
Impact end time: 29/07/2026, 17:26 UTC
Client actions: None
Resolved
This incident has been resolved.
Payout acceptance rates have returned to normal rates.
What happened: A change deployed on 20/07/2026 at 09:43 UTC inadvertently altered our payout retry logic, causing some errors that should have been retried to be treated as terminal. This resulted in a temporary increase in payout failure rates.
What we did: We identified the root cause, deployed a fix restoring the previous retry behaviour, and confirmed via monitoring that acceptance rates are back to baseline.
We apologise for any inconvenience caused and are working on preventative measures to avoid a recurrence.
Impact start time: 20/07/2026, 09:43 UTC
Impact end time: 29/07/2026, 17:26 UTC
Client actions: None
Monitoring
A fix was deployed yesterday at 17:26 UTC to restore the payout retry logic that was impacted by a release on 20/07/2026.
We are analysing volumes and failure rates this morning; we'll declare this incident as resolved once we assess that failure rates are back to normal baselines.
Impact start time: 20/07/2026, 09:43 UTC
Impact end time: 29/07/2026, 17:26 UTC
Client actions: None
Monitoring
A fix has been deployed to restore the payout retry logic that was impacted by a release on 20/07/2026.
We are monitoring to ensure full recovery and that payout acceptance rates return to baseline levels until tomorrow morning.
Impact start time: 20/07/2026, 09:43 UTC
Impact end time: 29/07/2026, 17:26 UTC
Client actions: None
Identified
We spotted an issue related to our logic with Payout retries, following a release made on 20/07/2026.
Clients may have experienced a slight increase in failure rates since 2026-07-20 09:43 UTC.
The team continuously works on the fix; we will keep you posted on any developments as we progress.
Impact start time: 20/07/2026, 09:43 UTC
Client actions: None
Identified
We spotted an issue related to our logic with Payout retries, following a release made on 20/07/2026.
Clients may have experienced a slight increase in failure rates since 2026-07-20 09:43 UTC.
We have identified the root cause and are actively working on a fix.
Impact start time: 20/07/2026, 09:43 UTC
Client actions: None
Investigating
We spotted an issue related to our logic with Payout retries, following a release made on 20/07/2026.
Clients may have experienced a slight increase in failure rates since 2026-07-20 09:43 UTC.
We have identified the root cause and are currently working on a fix.
We apologise for any inconvenience this may be causing and want to assure you that our team is working to resolve the issue as quickly as possible. We will keep you regularly updated on the progress toward resolution.
Impact start time: 20/07/2026, 09:43 UTC
Client actions: None